E-campus news

No, e-campus has not been hacked

 
This discussion has been locked so you can no longer reply to it.
Picture of Lydia Putnam
No, e-campus has not been hacked
by Lydia Putnam - Thursday, 20 December 2018, 9:28 AM
 
If you've tried to access e-campus today you probably got a warning message looking something like this:
picture of warning: "your connection is not private"
Don't worry--e-campus has not been hacked. All that happened is that our domain host forgot to update our security certificate. We've alerted them to the issue and it should be resolved sometime today.

In the meantime, if you need to access e-campus immediately, clicking on the "Advanced" button should allow you to create a security exception for this website, allowing you to use e-campus pretty much as normal, although things may look a little funky depending on the peculiarities of whatever browser you're using.

Apologies for the inconvenience, but we are working to get it sorted out ASAP.
Picture of Lydia Putnam
Re: No, e-campus has not been hacked - PROBLEM SOLVED
by Lydia Putnam - Thursday, 20 December 2018, 10:24 AM
 

We just received confirmation that the security certificate has been correctly updated, and everyone should now be able to access e-campus as usual. If you have the page already open, you may need to refresh it for things to start functioning correctly again.